Endicia for Mac 2.18.2

May 29, 2018

Important Information

  • On July 31st, due to security and compliance issues we will no longer be able to support macOS 10.6, 10.7 or 10.8. In order to connect to the Endicia servers after that date, Endicia for Mac must be running on macOS 10.9 or greater. We highly recommend upgrading to the latest version you can.

Changes and Improvements:

  • Added support for the DYMO Wireless LabelWriter.
  • Handles two line addresses (such as the Internal Revenue Service) correctly.

Download 2.18.2

See Latest Updates »